6

Broadcom 4353 Won't Connect And Times Out

view full story
linux-howto

http://forums.opensuse.org – Details: Dell Studio 17 Laptop OpenSuse 11.2 Drivers: broadcom-wl-kmp-desktop-5.60.48.36_2.6.31.12_0.1-7.pm.13.1.x86_64 broadcom-wl-5.60.48.36-7.pm.13.1.x86_64 # /sbin/lspci 08:00.0 Network controller: Broadcom Corporation Device 4353 (rev 01) # /sbin/lspci -n 08:00.0 0280: 14e4:4353 (rev 01) # /usr/sbin/iwconfig eth1 IEEE 802.11abgn ESSID:"" Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated Bit Rate:16 Mb/s Tx-Power:24 dBm Retry min limit:7 RTS thr:off Fragment thr:off Encryption key:off Power Managementmode:All packets received Link Quality=5/5 Signal level=0 dBm Noise level=-95 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0 # /usr/sbin/iwlist scan Cell 01 - Address: 00:14:6C:FB:7C:B4 ESSID:"pw-wireless" Mode:Managed Frequency:2.462 GHz (Channel 11) Quality:5/5 Signal level:-50 dBm Noise level:-95 dBm Encryption key:on Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s 24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s 12 Mb/s; 48 Mb/s ----------------------------- When I try to connect, nothing happens. On the same laptop booted into Windows, it works fine. Other pc's can connect to the network without any problem as well. In the NetworkworkManager log: Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled... Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) started... Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 2 of 5 (Device Configure) scheduled... Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) complete. Mar 13 00:48:56 linux-zr0n NetworkManager: <info> (eth1): supplicant connection state: scanning -> disconnected Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 2 of 5 (Device Configure) starting... Mar 13 00:48:56 linux-zr0n NetworkManager: <info> (eth1): device state change: 4 -> 5 (reason 0) Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Activation (eth1/wireless): connection 'pw-wireless' has security, and secrets exist. No new secrets needed. Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Config: added 'ssid' value 'pw-wireless' Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Config: added 'scan_ssid' value '1' Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Config: added 'key_mgmt' value 'NONE' Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Config: added 'wep_key0' value '<omitted>' Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Config: added 'wep_tx_keyidx' value '0' Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 2 of 5 (Device Configure) complete. Mar 13 00:48:56 linux-zr0n NetworkManager: <info> Config: set interface ap_scan to 1 Mar 13 00:48:56 linux-zr0n NetworkManager: <info> (eth1): supplicant connection state: disconnected -> scanning Mar 13 00:49:07 linux-zr0n NetworkManager: <info> (eth1): supplicant connection state: scanning -> associating Mar 13 00:49:12 linux-zr0n NetworkManager: <info> (eth1): supplicant connection state: associating -> disconnected Mar 13 00:49:12 linux-zr0n NetworkManager: <info> (eth1): supplicant connection state: disconnected -> associated Mar 13 00:49:12 linux-zr0n NetworkManager: <info> (eth1): supplicant connection state: associated -> completed Mar 13 00:49:12 linux-zr0n NetworkManager: <info> Activation (eth1/wireless) Stage 2 of 5 (Device Configure) successful. Connected to wireless network 'pw-wireless'. Mar 13 00:49:12 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) scheduled. Mar 13 00:49:12 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) started... Mar 13 00:49:12 linux-zr0n NetworkManager: <info> (eth1): device state change: 5 -> 7 (reason 0) Mar 13 00:49:12 linux-zr0n NetworkManager: <info> Activation (eth1) Beginning DHCP transaction. Mar 13 00:49:12 linux-zr0n NetworkManager: <info> dhclient started with pid 5702 Mar 13 00:49:12 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 3 of 5 (IP Configure Start) complete. Mar 13 00:49:12 linux-zr0n NetworkManager: <info> DHCP: device eth1 state changed normal exit -> preinit Mar 13 00:49:58 linux-zr0n NetworkManager: <info> Device 'eth1' DHCP transaction took too long (>45s), stopping it. Mar 13 00:49:58 linux-zr0n NetworkManager: <info> eth1: canceled DHCP transaction, dhcp client pid 5702 Mar 13 00:49:58 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 4 of 5 (IP Configure Timeout) scheduled... Mar 13 00:49:58 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 4 of 5 (IP Configure Timeout) started... Mar 13 00:49:58 linux-zr0n NetworkManager: <info> Activation (eth1/wireless): could not get IP configuration for connection 'pw-wireless'. Mar 13 00:49:58 linux-zr0n NetworkManager: <info> (eth1): device state change: 7 -> 6 (reason 0) Mar 13 00:49:58 linux-zr0n NetworkManager: <info> Activation (eth1/wireless): asking for new secrets Mar 13 00:49:58 linux-zr0n NetworkManager: <info> Activation (eth1) Stage 4 of 5 (IP Configure Timeout) complete. -------------------------- On every other machine and on this laptop when running Windows, It is WEP, Open system, Key Index 1, and the passphrase works except on this when running OpenSuse. It seems as if it just times out. Any ideas or suggestions? Thank you! (Distributions)