5

bluetooth module not recognized on Dell E6400

view full story
linux-howto

http://forums.fedoraforum.org – hello everybody, I'm using FC11 for longer time and for about last 3 kernel updates I'm not able to use bluetooth module at all. Gnome notification apllet is showing disabled interface, LED is turned on. It worked before perfectly before. After enabling BT, I see it in lsusb: Code: Bus 005 Device 002: ID 0a5c:5801 Broadcom Corp. when I enable module I see this in log: Code: Nov  4 14:02:26 localhost kernel: usb 3-1: new full speed USB device using uhci_hcd and address 20 Nov  4 14:02:26 localhost kernel: usb 3-1: New USB device found, idVendor=0a5c, idProduct=4500 Nov  4 14:02:26 localhost kernel: usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 Nov  4 14:02:26 localhost kernel: usb 3-1: Product: BCM2046B1 Nov  4 14:02:26 localhost kernel: usb 3-1: Manufacturer: Broadcom Nov  4 14:02:26 localhost kernel: usb 3-1: configuration #1 chosen from 1 choice Nov  4 14:02:26 localhost kernel: hub 3-1:1.0: USB hub found Nov  4 14:02:26 localhost kernel: hub 3-1:1.0: 3 ports detected Nov  4 14:02:27 localhost kernel: usb 3-1.1: new full speed USB device using uhci_hcd and address 21 Nov  4 14:02:27 localhost kernel: usb 3-1.1: New USB device found, idVendor=413c, idProduct=8157 Nov  4 14:02:27 localhost kernel: usb 3-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0 Nov  4 14:02:27 localhost kernel: usb 3-1.1: configuration #1 chosen from 1 choice Nov  4 14:02:27 localhost kernel: input: HID 413c:8157 as /devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.1/3-1.1:1.0/input/input26 Nov  4 14:02:27 localhost kernel: generic-usb 0003:413C:8157.000D: input,hidraw0: USB HID v1.11 Keyboard [HID 413c:8157] on usb-0000:00:1a.0-1.1/input0 Nov  4 14:02:27 localhost kernel: usb 3-1.2: new full speed USB device using uhci_hcd and address 22 Nov  4 14:02:27 localhost kernel: usb 3-1.2: New USB device found, idVendor=413c, idProduct=8158 Nov  4 14:02:27 localhost kernel: usb 3-1.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0 Nov  4 14:02:27 localhost kernel: usb 3-1.2: configuration #1 chosen from 1 choice Nov  4 14:02:27 localhost kernel: input: HID 413c:8158 as /devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.2/3-1.2:1.0/input/input27 Nov  4 14:02:27 localhost kernel: generic-usb 0003:413C:8158.000E: input,hidraw1: USB HID v1.11 Mouse [HID 413c:8158] on usb-0000:00:1a.0-1.2/input0 hid2hci gives me: Code: ERROR: Vendor ID, Product ID, and Switching Method must all be defined. Usage:         hid2hci [options] Options:         -h, --help          Display help         -q, --quiet          Don't display any messages         -r, --mode=          Mode to switch to [hid, hci]         -v, --vendor=        Vendor ID to act upon         -p, --product=      Product ID to act upon         -m, --method=        Method to use to switch [csr, logitech, dell] hcitool scan then returns Code: Device is not available: No such device I tried to google what I can but none useful found. My idea is that hardware was not recognized by kernel. Using single boot 2.6.30.9-90.fc11.i686.PAE thanks for help (HowTos)