2

Banshee doesn't mount Creative Zen player OpenSuse 11.2

view story
linux-howto

http://forums.opensuse.org – When logged in as my normal userid to OpenSuse 11.2, I cannot get Banshee to recognize my Creative Zen MP3 player. The player does appear as a device on the desktop and I can access files on the player through that icon, but cannot get Banshee to recognize it so it can be managed in Banshee. If however, I log on as root, Banshee recognizes the device without a problem. The log file in ~/.config/banshee-1 shows the following: libusb couldn't open USB device /dev/bus/usb/001/004: Permission denied. libusb requires write access to USB device nodes. libusb couldn't open USB device /dev/bus/usb/003/002: Permission denied. libusb requires write access to USB device nodes. libusb couldn't open USB device /dev/bus/usb/004/002: Permission denied. libusb requires write access to USB device nodes. libusb couldn't open USB device /dev/bus/usb/004/003: Permission denied. libusb requires write access to USB device nodes. usb_claim_interface(): Device or resource busy LIBMTP PANIC: Unable to initialize device [Warn 07:45:48.562] Caught an exception - Connecting (in `Mtp') at Mtp.Error.CheckError (ErrorCode errorCode) [0x00000] at Mtp.MtpDevice.GetConnectedDevices (System.IntPtr& list) [0x00000] at Mtp.MtpDevice.Detect () [0x00000] at Banshee.Dap.Mtp.MtpSource.DeviceInitialize (IDevice device) [0x00000] I have tried changing the owner and the permissions for the devices in /dev/bus/usb but that has not changed the behavior. Any suggestions as to how I fix the permissions to access this outside of root? (Distributions)