7

awesome 3.5.2: Volume Widget doesn't work anymore

view full story
linux-howto

https://bbs.archlinux.org – Hi folks,this volume widget doesn't work anymore after upgrading awesome:http://awesome.naquadah.org/wiki/Volume … nd_displayI get the errorvolume.lua:1: attempts to call global 'widget' (a nil value)This is the file:volume_widget = widget({ type = "textbox", name = "tb_volume", align = "right" }) function update_volume(widget) local fd = io.popen("amixer sget Master") local status = fd:read("*all") fd:close() local volume = tonumber(string.match(status, "(%d?%d?%d)%%")) / (HowTos)