2

AR5B91 seen as AR928X, wireless fails after minutes

view story
linux-howto

http://www.linuxforums.org – Hi, I'm pretty new to the drivers. I'm having problems with the current installed drivers for my Atheros AR5B91 Wireless Network Adapter. Specs Laptop: Code: Acer Aspire 5536-644G50Mn WLAN: Acer Nplify(TM) 802.11b/g/Draft-N MS Windows Vista says: Atheros AR5B91 Wireless Network Adapter. uname shows: Code: Kernel name: Linux Kernel release: 2.6.31.5-0.1-desktop Kernel version: #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 Machine, processor, hardware platform: x86_64 Operating System: GNU/Linux /sbin/lspci -vnn shows: Code: 06:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)         Subsystem: Lite-On Communications Inc Device [11ad:6600]         Flags: bus master, fast devsel, latency 0, IRQ 17         Memory at f0400000 (64-bit, non-prefetchable) [size=64K]         Capabilities: <access denied>         Kernel driver in use: ath9k lsmod shows: Code: Module        Size                Used by ath9k                279444        0 mac80211        257312        1 ath9k ath                        11048        1 ath9k cfg80211                123264        3 ath9k,mac80211,ath I had Ubuntu 9.10 installed... The Wi-Fi worked fine for several minutes. But then the connection with the network was lost and the NetworkManager tried to reconnect. Unfortunatly the NetworkManager failed completly and couldn't see any wireless networks anymore. This is what's shown after the failure: /sbin/lspci -vnn shows: Code: 06:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev ff) (prog-if ff)         !!! Unknown header type 7f         Kernel driver in use: ath9k /var/log/NetworkManager shows: Code: Dec 28 19:02:41 linux-7pzr NetworkManager: <info>  Config: set interface ap_scan to 1 Dec 28 19:02:41 linux-7pzr NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning Dec 28 19:02:56 linux-7pzr NetworkManager: <info>  wlan0: link timed out. Dec 28 19:03:06 linux-7pzr NetworkManager: <info>  Activation (wlan0/wireless): association took too long, failing activation. Dec 28 19:03:06 linux-7pzr NetworkManager: <info>  (wlan0): device state change: 5 -> 9 (reason 11) Dec 28 19:03:06 linux-7pzr NetworkManager: <info>  Activation (wlan0) failed for access point (dlink) Dec 28 19:03:06 linux-7pzr NetworkManager: <info>  Marking connection 'Auto dlink' invalid. Dec 28 19:03:06 linux-7pzr NetworkManager: <info>  Activation (wlan0) failed. Dec 28 19:03:06 linux-7pzr NetworkManager: <info>  (wlan0): device state change: 9 -> 3 (reason 0) Dec 28 19:03:06 linux-7pzr NetworkManager: <info>  (wlan0): deactivating device (reason: 0). I tried wicd instead of NetworkManager but kept the same problem. Then I installed Fedora 12 and now OpenSuse 11.2 but the problem remains. Seems to me I have the right driver (ath9k is good what i learned) but wrong configured assuming the "AR928X" output. Anyone an idea what to do? Thanks, Martijn (HowTos)