1

apt-get, older package versions and dependency resolution

view story
linux-howto

http://serverfault.com – I'm trying to install a slightly older version of puppet (2.7.8 as opposed to 2.7.9) for consistency purposes among a cluster of servers I manage. However, when I attempt to do so, apt-get throws a mysterious error: xxxx@xxx-xxx-xxx-xxx:~$ sudo apt-get install puppet=2.7.8-1puppetlabs1 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of In (HowTos)