1

In-app billing - error in generated IInAppBillingService.java

view story
linux-howto

http://stackoverflow.com – Trying to use in-app billing V3 for the first time, targeting Android 2.2 (API level 8), using Eclipse. Created a package (in /src) called com.android.vending.billing, dropped (imported) IInAppBillingService.aidl into it. But /gen now contains build errors, eg for @Override public int isBillingSupported(int apiVersion, java.lang.String packageName, java.lang.String type) throws android.os.RemoteException it says "The method isBillingSupported(int, String, String) of type IInAppBillingService.Stub.Proxy must override a superclass method ... ". It recommends I remove the @override but this (HowTos)