6

any url opens same site on debian lenny

view full story
linux-howto

http://www.linuxquestions.org – Hello, I installed for the sheer pleasure of it a webserver. includes apache2, postfix mail server, MySQL, MyDNS nameserver, PureFTPd, SpamAssassin, ClamAV, etc etc. (I have tried to use the config panels ispconfig and webmin) The situation: There are 3 sites listed on the server, All 3 on different virtual hosts (obviously). The http access goes trough the 20080 port since my ISP blocks everything below 1024 (the bastards). I use a linksys router (192.168.1.1) with dmz pointing to 192.168.1.100 (server) The sites on the server: inphone.be fraksken.be fraksken.is-a-geek.org (but appearently not geek enough) I also gave them own IP's: 192.168.1.95 192.168.1.96 192.168.1.100 (respectivly) The problem: I uploaded a site to the dir of fraksken.be (the first installed domain on the server) and it doesn't matter to what site you go, you'll end up at the site of fraksken.be I just don't get it anymore. I setup the correct dns values (I think), the virtual domains are active, and working, the correct dirs are made, ... There must be something I did wrong since i've tried it with centos and debian, and both end up with the same problems (more or less). anybody who requests access to the ispconfig panel to view settings or wants ssh, just pm me, I'd be glad to give them if you can help me find the cause of the problem and help me fix and understand it. P.S. For the installation I used: perfect server guide I'm thinking the problem should be somewhere in the router maybe? But should it be, how can I fix it? Thanks :) EDIT: Apache refuses to bootup again :s why do my hobbies frustrate me so much :'( (HowTos)