3

[64 bit] Why does Totem require i386 gstreamer packages on amd64 system?

view full story
linux-howto

http://ubuntuforums.org – Whenever I click on an MKV file, Totem opens and complains that the required packages are not installed. It wants to install "gstreamer0.10-plugins-base (i386)". I wonder why though, I have "gstreamer0.10-plugins-base" installed. The amd64 version that is. There should be no need to install the i386 version, right? It is my understanding that i386 packages on an amd64 system should only be there for exceptional cases, like flashplugin, acroread, or vmware or some other i386-only binary distro. Totem hardly qualifies as an exceptional case, the gstreamer base plugins are (Hardware)